C:\Ruby Projects\Ruby On Rails Tutorial\environment\hello_app>bundle _2.3.14_ install Fetching gem metadata from https://rubygems.org/........... Resolving dependencies...... Using rake 13.0.6 Using concurrent-ruby 1.2.2 Using minitest 5.20.0 Using builder 3.2.4 Using erubi 1.12.0 Using crass 1.0.6 Using rack 2.2.8 Using nio4r 2.5.9 Using websocket-extensions 0.1.5 Using marcel 1.0.2 Using bundler 2.3.14 Using mini_mime 1.1.5 Fetching racc 1.7.1 Using matrix 0.4.2 Fetching date 3.3.3 Fetching timeout 0.4.0 Fetching public_suffix 5.0.3 Fetching bindex 0.8.1 Fetching msgpack 1.7.2 Fetching regexp_parser 2.8.2 Fetching childprocess 4.1.0 Installing timeout 0.4.0 Installing bindex 0.8.1 with native extensions Installing racc 1.7.1 with native extensions Installing date 3.3.3 with native extensions Installing childprocess 4.1.0 Installing msgpack 1.7.2 with native extensions Installing regexp_parser 2.8.2 Installing public_suffix 5.0.3 Fetching ffi 1.16.3 (x64-mingw-ucrt) Installing ffi 1.16.3 (x64-mingw-ucrt) Using method_source 1.0.0 Using thor 1.3.0 Using zeitwerk 2.6.12 Fetching rexml 3.2.6 Fetching rubyzip 2.3.2 Installing rubyzip 2.3.2 Fetching tilt 2.3.0 Installing rexml 3.2.6 Installing tilt 2.3.0 Fetching websocket 1.2.10 Installing websocket 1.2.10 Fetching sqlite3 1.4.2 Using i18n 1.14.1 Using tzinfo 2.0.6 Using rack-test 2.1.0 Fetching puma 5.6.4 Fetching sprockets 4.2.1 Installing sqlite3 1.4.2 with native extensions Installing puma 5.6.4 with native extensions Installing sprockets 4.2.1 Using websocket-driver 0.7.6 Fetching net-protocol 0.2.1 Installing net-protocol 0.2.1 Fetching addressable 2.8.5 Installing addressable 2.8.5 Using activesupport 7.0.4 Fetching sassc 2.4.0 Fetching selenium-webdriver 4.2.0 Installing sassc 2.4.0 with native extensions Installing selenium-webdriver 4.2.0 Fetching net-pop 0.1.2 warning: database file for 'clangarm64' does not exist (use '-Sy' to download) Installing net-pop 0.1.2 Fetching net-smtp 0.4.0 Installing net-smtp 0.4.0 Using globalid 1.2.1 Using activemodel 7.0.4 Using activejob 7.0.4 Using activerecord 7.0.4 warning: database file for 'clang32' does not exist (use '-Sy' to download) error: failed to prepare transaction (could not find database) Using nokogiri 1.15.4 (x64-mingw-ucrt) Using rails-dom-testing 2.2.0 Using loofah 2.21.4 Fetching xpath 3.2.0 Fetching webdrivers 5.0.0 Using rails-html-sanitizer 1.6.0 Using actionview 7.0.4 Using actionpack 7.0.4 Fetching jbuilder 2.11.5 Installing xpath 3.2.0 Installing webdrivers 5.0.0 Using actioncable 7.0.4 Using activestorage 7.0.4 Using railties 7.0.4 Fetching sprockets-rails 3.4.2 Installing sprockets-rails 3.4.2 Using actiontext 7.0.4 Fetching capybara 3.37.1 Installing jbuilder 2.11.5 Fetching importmap-rails 1.1.0 Installing capybara 3.37.1 Fetching stimulus-rails 1.0.4 Installing importmap-rails 1.1.0 Installing stimulus-rails 1.0.4 Fetching turbo-rails 1.1.1 Fetching web-console 4.2.0 Installing web-console 4.2.0 Installing turbo-rails 1.1.1 Fetching net-imap 0.4.2 Installing net-imap 0.4.2 Using mail 2.8.1 Using actionmailer 7.0.4 Using actionmailbox 7.0.4 Using rails 7.0.4 Fetching bootsnap 1.12.0 Installing bootsnap 1.12.0 with native extensions Fetching sassc-rails 2.1.2 Installing sassc-rails 2.1.2 Gem::Ext::BuildError: ERROR: Failed to build gem native extension. current directory: C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/sqlite3-1.4.2/ext/sqlite3 C:/Ruby31-x64/bin/ruby.exe -I C:/Ruby31-x64/lib/ruby/3.1.0 -r ./siteconf20231024-6216-ln3104.rb extconf.rb checking for sqlite3.h... no sqlite3.h is missing. Install SQLite3 from http://www.sqlite.org/ first. *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby31-x64/bin/$(RUBY_BASE_NAME) --with-sqlcipher --without-sqlcipher --with-sqlite3-dir --without-sqlite3-dir --with-sqlite3-include --without-sqlite3-include=${sqlite3-dir}/include --with-sqlite3-lib --without-sqlite3-lib=${sqlite3-dir}/lib --with-sqlite3-config --without-sqlite3-config --with-pkg-config --without-pkg-config --with-sqlcipher --without-sqlcipher To see why this extension failed to compile, please check the mkmf.log which can be found here: C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/sqlite3-1.4.2/mkmf.log extconf failed, exit code 1 Gem files will remain installed in C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/sqlite3-1.4.2 for inspection. Results logged to C:/Ruby31-x64/lib/ruby/gems/3.1.0/extensions/x64-mingw-ucrt/3.1.0/sqlite3-1.4.2/gem_make.out C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:95:in `run' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:47:in `block in build' C:/Ruby31-x64/lib/ruby/3.1.0/tempfile.rb:317:in `open' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/ext_conf_builder.rb:26:in `build' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:161:in `build_extension' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:195:in `block in build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in `each' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/ext/builder.rb:192:in `build_extensions' C:/Ruby31-x64/lib/ruby/3.1.0/rubygems/installer.rb:853:in `build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/rubygems_gem_installer.rb:71:in `build_extensions' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/rubygems_gem_installer.rb:28:in `install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/source/rubygems.rb:204:in `install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/installer/gem_installer.rb:54:in `install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/installer/parallel_installer.rb:186:in `do_install' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/worker.rb:62:in `apply_func' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/worker.rb:57:in `block in process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/worker.rb:54:in `loop' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/worker.rb:54:in `process_queue' C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/bundler-2.3.14/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads' An error occurred while installing sqlite3 (1.4.2), and Bundler cannot continue. In Gemfile: sqlite3 C:\Ruby Projects\Ruby On Rails Tutorial\environment\hello_app>ruby -v ruby 3.1.2p20 (2022-04-12 revision 4491bb740a) [x64-mingw-ucrt]